Back to overview
Degraded
Update
Dec 17 at 06:54pm IST
Resolved
Dec 18 at 10:43am IST
the update is over
Affected services
Updated
Dec 17 at 06:57pm IST
Some servers get down to the updated
Affected services
Created
Dec 17 at 06:54pm IST
Fortnite lego get a new update
Affected services