Back to overview
Degraded

Bug

Dec 19 at 12:12am IST

Resolved
Dec 19 at 12:18am IST

The bug is get over all the servers get online

Created
Dec 19 at 12:12am IST

The festival mod have a bug on the servers