Back to overview
Degraded
Fortnite - CCU, Battle Pass and Player Rank not Updating Correctly
Jan 25 at 11:00pm IST
Resolved
Jan 26 at 04:34pm IST
over
Affected services
Created
Jan 25 at 11:00pm IST
Investigating - We are currently investigating visual CCU numbers in game experiences, Battle Passes appearing blank for some players, and player ranks not appearing to update after a ranked game.
Affected services