Back to overview
Downtime
Fortnite: Downtime for 28.20 update
Feb 07 at 11:42am IST
Resolved
Feb 07 at 02:35pm IST
.
Affected services
Updated
Feb 07 at 11:43am IST
Scheduled - We will be undergoing scheduled maintenance during this time.
Affected services
Created
Feb 07 at 11:42am IST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Affected services